<!DOCTYPE html>
<html lang="en" dir="ltr" prefix="content: http://purl.org/rss/1.0/modules/content/  dc: http://purl.org/dc/terms/  foaf: http://xmlns.com/foaf/0.1/  og: http://ogp.me/ns#  rdfs: http://www.w3.org/2000/01/rdf-schema#  schema: http://schema.org/  sioc: http://rdfs.org/sioc/ns#  sioct: http://rdfs.org/sioc/types#  skos: http://www.w3.org/2004/02/skos/core#  xsd: http://www.w3.org/2001/XMLSchema# ">
<head>  <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
  new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
  j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
  'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
  })(window,document,'script','dataLayer','GTM-NLVSMW2');</script>

  <meta charset="utf-8" />
<meta name="title" content="Test First approach sounds simply enough, right?   | Scrum.org" />
<meta name="twitter:card" content="summary" />
<meta property="og:site_name" content="Scrum.org" />
<meta name="twitter:title" content="Test First approach sounds simply enough, right?" />
<meta name="twitter:description" content="As the name &quot;Test First&quot; suggests, you write a test first before the actual code and keep them running all the time. Well maybe not the second part explicitly. Yet what if I said to you that it actual means more than that?" />
<meta name="description" content="As the name &quot;Test First&quot; suggests, you write a test first before the actual code and keep them running all the time. Well maybe not the second part explicitly. Yet what if I said to you that it actual means more than that?" />
<meta name="twitter:site:id" content="@Scrumdotorg" />
<meta property="og:url" content="https://www.scrum.org/resources/blog/test-first-approach-sounds-simply-enough-right" />
<meta name="image_src" content="" />
<meta property="og:title" content="Test First approach sounds simply enough, right?" />
<meta name="twitter:url" content="https://www.scrum.org/resources/blog/test-first-approach-sounds-simply-enough-right" />
<meta property="og:description" content="As the name &quot;Test First&quot; suggests, you write a test first before the actual code and keep them running all the time. Well maybe not the second part explicitly. Yet what if I said to you that it actual means more than that?" />
<meta name="twitter:image" content="https://www.scrum.org/themes/custom/scrumorg/assets/images/logo-250.png" />
<meta property="og:image" content="https://www.scrum.org/themes/custom/scrumorg/assets/images/logo-250.png" />
<meta name="Generator" content="Drupal 8 (https://www.drupal.org)" />
<meta name="MobileOptimized" content="width" />
<meta name="HandheldFriendly" content="true" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<link rel="shortcut icon" href="/themes/custom/scrumorg/favicon.ico" type="image/vnd.microsoft.icon" />
<link rel="canonical" href="https://www.scrum.org/resources/blog/test-first-approach-sounds-simply-enough-right" />
<link rel="shortlink" href="https://www.scrum.org/node/39589" />
<link rel="revision" href="https://www.scrum.org/resources/blog/test-first-approach-sounds-simply-enough-right" />

          <link rel="alternate" type="application/rss+xml" title="RSS" href="/resources/blog/rss.xml" />
        <title>Test First approach sounds simply enough, right?   | Scrum.org</title>
    <link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/ajax-progress.module.css?qapico" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/align.module.css?qapico" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/autocomplete-loading.module.css?qapico" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/fieldgroup.module.css?qapico" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/container-inline.module.css?qapico" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/clearfix.module.css?qapico" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/details.module.css?qapico" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/hidden.module.css?qapico" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/item-list.module.css?qapico" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/js.module.css?qapico" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/nowrap.module.css?qapico" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/position-container.module.css?qapico" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/progress.module.css?qapico" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/reset-appearance.module.css?qapico" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/resize.module.css?qapico" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/sticky-header.module.css?qapico" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/system-status-counter.css?qapico" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/system-status-report-counters.css?qapico" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/system-status-report-general-info.css?qapico" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/tabledrag.module.css?qapico" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/tablesort.module.css?qapico" />
<link rel="stylesheet" media="all" href="/core/themes/stable/css/system/components/tree-child.module.css?qapico" />
<link rel="stylesheet" media="all" href="/modules/contrib/video_embed_field/css/video_embed_field.responsive-video.css?qapico" />
<link rel="stylesheet" media="all" href="/themes/custom/scrumorg/css/scrumorg.style.css?qapico" />
<link rel="stylesheet" media="all" href="//fonts.googleapis.com/css?family=Raleway:200,400,700,700italic,400italic" />
<link rel="stylesheet" media="all" href="//fonts.googleapis.com/css?family=Roboto+Slab:400,700" />

    
<!--[if lte IE 8]>
<script src="/core/assets/vendor/html5shiv/html5shiv.min.js?v=3.7.3"></script>
<![endif]-->

</head>

<body  class="path-node page-node-type-blog-post node" >
<a href="#main-content" class="visually-hidden focusable">
  Skip to main content
</a>

  <div class="dialog-off-canvas-main-canvas" data-off-canvas-main-canvas>
    

<header class="site-header" id="js-site-header">
  <div class="site-header-wrapper">
    <div class="site-header-container">
      <div class="site-header-row">
        <div class="site-header-logo-wrapper">
          <a href="/">
            <span class="visually-hidden">Home</span>
            <svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 1236.55 400"><path d="M446.23,136.46c-4.81-6.78-13.37-10-22.11-10-10.34,0-20.68,4.64-20.68,16.23,0,25.32,59.91,10.88,59.91,55.82,0,27.1-21.4,40.3-46.18,40.3-15.7,0-31-4.82-41.37-17.12l16.94-16.41a29.77,29.77,0,0,0,25,13.2c10.34,0,22.11-5.71,22.11-17.3,0-27.64-59.91-11.77-59.91-56.89,0-26,23.18-38.16,46.54-38.16,13.2,0,26.39,3.75,36.2,13Z" style="fill:#405870"/><path d="M539.68,175.69c-5-5.17-10.52-8.56-16.23-8.56-15.69,0-25.14,12.31-25.14,25.68s9.45,25.68,25.14,25.68a20.56,20.56,0,0,0,16.59-8L554.3,225.8c-8.74,8.74-23.36,11.95-30.85,11.95-25.86,0-46.54-18-46.54-44.94s20.68-44.94,46.54-44.94c10.88,0,22.83,3.92,31,13Z" style="fill:#405870"/><path d="M569.28,150h21.4v13.55H591c4.64-9.8,14.09-15.69,25.32-15.69a27.72,27.72,0,0,1,7.67,1.25v20.69a42.51,42.51,0,0,0-10.34-1.61c-20.15,0-23,16.94-23,21.58v45.83h-21.4Z" style="fill:#405870"/><path d="M718,235.61H697.68V221.88h-.36c-3.92,8.56-11.94,15.87-26.21,15.87-23,0-31.21-16.23-31.21-33.71V150h21.4v43.33c0,9.46.71,25.15,15.69,25.15,14.09,0,19.62-10.34,19.62-21.76V150H718Z" style="fill:#405870"/><path d="M738.52,150h20.33v13.38h.36c3.74-8,11.94-15.52,26.21-15.52,13.19,0,22.29,5.17,26.75,15.87,6.24-10.88,15.33-15.87,28.17-15.87,22.83,0,30.85,16.23,30.85,36.74v51h-21.4V187.1c0-10.7-3.21-20-15.87-20-13.37,0-18.36,11.06-18.36,22.11v46.37h-21.4v-51c0-10.52-4.28-17.48-14.63-17.48-14.08,0-19.61,10.34-19.61,21.76v46.72h-21.4Z" style="fill:#405870"/><path d="M902.05,219.56a8.56,8.56,0,1,1-8.56,8.56A8.45,8.45,0,0,1,902.05,219.56Z" style="fill:#405870"/><path d="M970.17,151.08c25.32,0,43.33,18.19,43.33,43.33s-18,43.34-43.33,43.34-43.33-18.19-43.33-43.34S944.85,151.08,970.17,151.08Zm0,77c20.15,0,32.63-15.16,32.63-33.71s-12.48-33.7-32.63-33.7-32.63,15.16-32.63,33.7S950,228.12,970.17,228.12Z" style="fill:#405870"/><path d="M1032.94,176.4c0-6.06-.89-18.9-.89-23.18h10.7c.18,6.06.36,12.84.72,14.45,5.34-9.63,13.9-16.59,26.21-16.59a25.34,25.34,0,0,1,6.24.89l-1.25,10.52a13.29,13.29,0,0,0-4.1-.71c-18.55,0-26.93,12.84-26.93,28.89v44.94h-10.7Z" style="fill:#405870"/><path d="M1168.3,230.26c0,41-27.11,48.15-43.87,48.15-16.59,0-32.46-6.42-40.84-17.3l8.38-7.85c7.49,10.52,19.62,15.52,32.46,15.52,32.63,0,33.17-28.54,33.17-37.81V219.56h-.36c-6.24,9.81-17.12,16.05-31.21,16.05-24.25,0-44-19.08-44-42.27s19.79-42.26,44-42.26c14.09,0,25,6.24,31.21,16h.36V153.22h10.7Zm-43-69.55A32.64,32.64,0,1,0,1158,193.34,32.64,32.64,0,0,0,1125.32,160.71Z" style="fill:#405870"/><path d="M95.92,193.77A110.9,110.9,0,0,1,110.19,159a122.68,122.68,0,0,1,23.53-27.48A120.51,120.51,0,0,0,115,152a95.34,95.34,0,0,1,13.09-14.78,97.39,97.39,0,0,1,16-11.87A77,77,0,0,1,137.7,131c-2.33,2-4.32,4-4.63,5.24a130.79,130.79,0,0,0-29.77,39.52A122,122,0,0,0,91,223.84,30.42,30.42,0,0,1,91.46,207c1.41-4.74,3.39-8.76,4.46-13.23" style="fill:#415870"/><path d="M178,111c-3.17,1-6.22,2.08-9.2,3.25A53,53,0,0,1,178,111" style="fill:#415870"/><path d="M216.75,328.48c3.4-.37,6.78-.89,10-1.41a56.36,56.36,0,0,1-10,1.41" style="fill:#415870"/><path d="M101.17,236.71l1.49,5.55a114.25,114.25,0,0,0,14.57,41.22,133.08,133.08,0,0,1-11.13-22.35,74.46,74.46,0,0,1-4.93-24.42" style="fill:#415870"/><path d="M103.5,221.16a82.53,82.53,0,0,1,10.83-40.4,91.54,91.54,0,0,0-10.83,40.4" style="fill:#415870"/><path d="M287.39,267.7c-.28-.1-.36-.41-.35-.78a2.41,2.41,0,0,0,.14-1,93.07,93.07,0,0,0,7-12.21,24.35,24.35,0,0,1-.6,3.48,35.75,35.75,0,0,1-3.27,4.93,22.4,22.4,0,0,0-2.9,5.55" style="fill:#415870"/><path d="M213,328.71l-.36.15c-1.17.08-2.33.16-3.48.2l-.42-.1c1.42-.1,2.83-.19,4.26-.25" style="fill:#415870"/><path d="M284.05,272.67a2.84,2.84,0,0,0-1.59-.37c1.65-2,3.22-4.14,4.69-6.31a8.93,8.93,0,0,0-.11.93c-.53,1.72-2.47,3.74-3,5.75" style="fill:#415870"/><path d="M235.08,303.26c-1.54.49-2.65,1.91-3.34,2.38-4.3.29-8.54.31-13.44.27-.74.36-2.33.49-3.83,1.11-.92-.42-1.89-.76-2.91-1.11A88.46,88.46,0,0,0,244,300.12a52.1,52.1,0,0,1-8.89,3.14" style="fill:#415870"/><path d="M185.66,127.71c8.17-2.64,17.51-3.45,26.6-3.1s18,1.68,26.48,2.55c-9.22-3.66-21.05-5.72-31-6.25s-17.88-.14-19.95-2.14,5.08-4,15-4.38a102.23,102.23,0,0,1,15.83.79c5.31.64,10.36,1.64,14.45,2.42-2.07-.93-2.07-.93-4.17-1.8,2.11.87,4.17,1.77,6.21,1.66a76.18,76.18,0,0,0-8.12-3.08c-2.94-1-5.7-1.89-6.91-2.75,1.39-.29,2.78-.52,4.19-.75-5.64-2.48-14.31-4-23.14-4.25s-17.76.54-24.3.64a165,165,0,0,1,48.82,1.7,133.13,133.13,0,0,1,48.45,19.64,119.61,119.61,0,0,1,37.36,39.45,113.45,113.45,0,0,1,15.33,51.83A132.21,132.21,0,0,1,286.2,324.78a77.6,77.6,0,0,1-13.65,9.11,111.06,111.06,0,0,1-18.62,7.92c-20.16,8.08-42.57,10.92-64.61,8.93-23.44-3-45.41-13.57-63-29.31S95.15,284.69,87.62,260.8c-1.55-4.75-1.72-10.82-.7-12.61.5-.9,1.25-.76,2.26,1s2.31,5.2,4.39,10.72a146.36,146.36,0,0,0,31.71,48.61c-1.32-.29-3.47-2.25-5.62-4.57a81.79,81.79,0,0,0-6.12-6.35,101.65,101.65,0,0,0,13.06,15.92,100,100,0,0,0,15.89,12.83A124.31,124.31,0,0,1,120.39,308a127,127,0,0,0,29.48,23,115.37,115.37,0,0,0,36.65,13.16c4.69.9,8.95,2.71,13.92,3.92a32,32,0,0,0,17.41-.3,126,126,0,0,1-50.3-10.38,134.87,134.87,0,0,1-42.27-28.91.79.79,0,0,0,.2,0,117.34,117.34,0,0,1-24.72-36c2,4.11,4.44,8.12,6.26,11.73-9.64-19.2-14.86-39.9-14.68-60.83a139.52,139.52,0,0,0,10.82,43.15,124.82,124.82,0,0,0,25,37.61A116.65,116.65,0,0,0,165.34,330a107.49,107.49,0,0,0,43.2,8.94c-8.08-1.41-17.37-2.37-26.28-4.54s-17.29-5.49-22.77-10.06a118.07,118.07,0,0,0,76.94,10.95L230.74,337a77.68,77.68,0,0,0,25-6.27,136,136,0,0,0,22.66-12.59c1.26-.83,2.51-1.67,3.75-2.56l-3.75,2.56a118,118,0,0,1-42,17.09c6.54-2,13.42-4.15,21.47-7.34-4.67,1-11.07,2.9-17.61,4.15a109,109,0,0,1-25.77,3.41,89.55,89.55,0,0,0,36.84-9.44c-16.84,5.45-35.26,7.74-52.69,5a106.4,106.4,0,0,0,28.75-1,106.39,106.39,0,0,0,45.68-16.52l-1.53,1.13c1.06-.69,2.08-1.44,3.1-2.17a104.61,104.61,0,0,0,15.06-12.48,62.75,62.75,0,0,0,10-14.2l1.61-2.38c-.64,1.76-.76,2.79,1.43,0a72.38,72.38,0,0,0,11-20.84c2.78-7.72,4.82-15.87,7-24.39,1.13-4.49,1.4-10.76.84-17.42a5.38,5.38,0,0,0-.36-3.6c-.16-1.43-.36-2.87-.58-4.3a59.71,59.71,0,0,0-1.92-10.36c.69,3.36,1.38,6.84,1.92,10.36l.4,3.94a8.94,8.94,0,0,1-1.19-3.72,108.62,108.62,0,0,1-3.31,36.41,116,116,0,0,1-15.23,33.94c.5-1.46,1.32-3.45,1.55-4.33-.95,2.28-2,4.5-3.16,6.71a121.19,121.19,0,0,1-15.79,18.47,29.08,29.08,0,0,0,3.95-5.44,114.49,114.49,0,0,1-27.71,20.22,112.31,112.31,0,0,1-32.74,11,108.2,108.2,0,0,1-62.25-11.4,85.16,85.16,0,0,0,33.5,12.37,104.69,104.69,0,0,1-46.39-16.24A99.47,99.47,0,0,1,118.89,279c4.44,4.23,10.21,9.86,14.22,11.06.56-.82-5.17-8.89-1.15-4.71,7.59,7.27,14.24,13.05,20.34,17.07s11.64,6.08,16.56,5.2c1-.39-2.68-4.33-5.24-8.12s-4.21-7.22-1.26-5.82a104.84,104.84,0,0,0,23.14,9.92,59.41,59.41,0,0,0,8.8,2.64c.37.2,1.09,0,2-.23,10.9,1.84,21.39,1.13,27.18.61,2.16-.15,4.3-.44,6.43-.77a10,10,0,0,1,3.09.61c1.23-.75,2.47-1.43,3.71-2a78.66,78.66,0,0,0,16.14-6.05,71.23,71.23,0,0,0,8.94-3.74c-.28-.28-1-.4-.71-1.06a81.48,81.48,0,0,0,16.1-14.12,62,62,0,0,1,6.69-5c.92-4.22,4.09-9.78,7-16.23s5.45-13.68,6.26-19.91H297a88.49,88.49,0,0,0,1.41-19c.28-1.07.6-2.11,1-3.1-.69-1.55-.91-3.22-1.3-4-.22-5.16-.47-9.6-1-14.09-.51-.7-2-1.83-2.58-3.42a58.26,58.26,0,0,0-3.71-9.16,97.45,97.45,0,0,0-5.19-10.17,95.3,95.3,0,0,0-25.92-28.77,2.86,2.86,0,0,1,.27-1.61c-2.1-.49-4.32-2.39-6.14-2.88.39,0,.69-.09.77-.37a26.13,26.13,0,0,1-5.94-2.78,37.31,37.31,0,0,0-5.32-3.17,26.43,26.43,0,0,0-3.65-.48c-.56-.24-1.12-.44-1.68-.67-5.3-4.1-11.81-4.6-18.73-5.23a95,95,0,0,0-21.22-1.2c-5.65.42-8.12-.59-12.3-.55" style="fill:#415870"/><path d="M294.88,252.17a90.11,90.11,0,0,0,5.87-17.63c-.9,6.58-1.63,12.79-5.87,17.63" style="fill:#415870"/><path d="M159.74,289.81a55.73,55.73,0,0,0-4.39-6.67,81.9,81.9,0,0,0,38.26,20.6v.12c-5.89-1-12.72-3.77-18.67-6.82s-11.17-6.24-15.2-7.23" style="fill:#415870"/><path d="M287,266.92a8.93,8.93,0,0,1,.11-.93l0,0a2.59,2.59,0,0,1-.14,1" style="fill:#415870"/><path d="M123.05,279.94l-.93-1.53a122.38,122.38,0,0,0,8.43,10.78,57.38,57.38,0,0,1-7.5-9.25" style="fill:#415870"/><path d="M108.29,233.8a102.43,102.43,0,0,1,.29-27.65A81.66,81.66,0,0,1,122,174.56a104.14,104.14,0,0,0-13.71,59.24" style="fill:#415870"/><path d="M141.56,267.89a67.07,67.07,0,0,1-3.1-8.7,76.58,76.58,0,0,0,4.19,8c-.62-.28-.8.4-1.09.66" style="fill:#415870"/><path d="M149.83,306.79l-2.22-1.65c2.08,1.18,4.19,2.29,6.34,3.29-.85-.26-2.74-1.1-4.12-1.64" style="fill:#415870"/><path d="M132.39,237.05q.36,3.28,1,6.53c-.55-1.22-1.13-2.41-1.82-3.61a9.66,9.66,0,0,0,.78-2.92" style="fill:#415870"/><path d="M133.54,203.26a56.27,56.27,0,0,1,2.89-8.24,90.22,90.22,0,0,0-2.73,10.14c-.19-.86-.36-1.56-.16-1.9" style="fill:#415870"/><path d="M160.05,65a86.36,86.36,0,0,1,24.4,16,94.92,94.92,0,0,1,17.43,22A93.18,93.18,0,0,0,189,85.78a74.62,74.62,0,0,1,9.32,12.15A77,77,0,0,1,205,111.85a56.48,56.48,0,0,1-3.35-5.71c-1.17-2-2.39-3.87-3.32-4.29a101.17,101.17,0,0,0-25.67-28.52,94.64,94.64,0,0,0-34.78-16.49,23.48,23.48,0,0,1,12.75,2.84c3.41,1.78,6.17,3.89,9.42,5.36" style="fill:#189ab6"/><path d="M211,139.82c-.29-2.57-.66-5-1.11-7.49a40.05,40.05,0,0,1,1.11,7.49" style="fill:#189ab6"/><path d="M39.58,137.1c-.22,2.64-.33,5.29-.41,7.85a41.47,41.47,0,0,1,.41-7.85" style="fill:#189ab6"/><path d="M126.57,62.68l-4.44.31a88.71,88.71,0,0,0-33.55,5,102.56,102.56,0,0,1,18.68-5.16,57.46,57.46,0,0,1,19.31-.14" style="fill:#189ab6"/><path d="M138.06,66.76A63.87,63.87,0,0,1,167.23,81a70.88,70.88,0,0,0-29.17-14.23" style="fill:#189ab6"/><path d="M75.4,199.88c.12-.19.36-.2.64-.14a2.07,2.07,0,0,0,.72.25A73.37,73.37,0,0,0,85,207.12a20.93,20.93,0,0,1-2.57-1,26.87,26.87,0,0,1-3.26-3.22,17.66,17.66,0,0,0-3.8-3" style="fill:#189ab6"/><path d="M40,134.17l-.07-.29c.12-.9.22-1.8.37-2.68l.13-.31c-.13,1.1-.27,2.19-.43,3.28" style="fill:#189ab6"/><path d="M72.1,196.6a2.08,2.08,0,0,0,.53-1.14c1.3,1.55,2.66,3,4.1,4.5a4.92,4.92,0,0,0-.69-.22c-1.23-.66-2.48-2.44-3.94-3.14" style="fill:#189ab6"/><path d="M56.06,154.79a9.43,9.43,0,0,0-1.31-2.9c.41-3.31,1-6.55,1.78-10.27-.16-.62,0-1.85-.28-3.08a23,23,0,0,0,1.28-2A68.56,68.56,0,0,0,57.14,162a41.94,41.94,0,0,1-1.08-7.24" style="fill:#189ab6"/><path d="M197.06,143.16a60.85,60.85,0,0,1-1.58,20.72c-1.6,6.91-3.94,13.47-5.86,19.79,4.15-6.49,7.47-15.2,9.34-22.65s2.76-13.6,4.58-14.88,2.33,4.47,1.11,12.08a78.09,78.09,0,0,1-2.94,11.94c-1.28,4-2.78,7.65-4,10.65,1-1.43,1-1.43,2-2.91a11.78,11.78,0,0,0-2.18,4.48,58.4,58.4,0,0,0,3.55-5.73,26.28,26.28,0,0,1,3.12-4.84c0,1.09,0,2.19-.06,3.3,2.73-3.93,5.15-10.32,6.67-17s2.22-13.6,3.11-18.59a127.78,127.78,0,0,1-8.53,36.92,102.85,102.85,0,0,1-22.13,34A92.8,92.8,0,0,1,147.69,233,88.05,88.05,0,0,1,106,237a102.56,102.56,0,0,1-73.85-46.49,60.07,60.07,0,0,1-4.92-11.75,86.37,86.37,0,0,1-3.27-15.36,108.9,108.9,0,0,1,2.77-50.51A91.17,91.17,0,0,1,58.34,69.25a105.18,105.18,0,0,1,51.89-20.46c3.86-.47,8.5.29,9.71,1.34.62.51.4,1.06-1.12,1.57A70.35,70.35,0,0,1,110,53.45a113.27,113.27,0,0,0-41.7,17c.41-1,2.22-2.31,4.3-3.61a61.7,61.7,0,0,0,5.74-3.72,79.59,79.59,0,0,0-14.06,7.59,78.18,78.18,0,0,0-12.12,10.2A96.75,96.75,0,0,1,69.42,66.75a98.37,98.37,0,0,0-21.9,19,89.43,89.43,0,0,0-15.45,26c-1.38,3.43-3.39,6.4-5.05,10a24.86,24.86,0,0,0-2.35,13.31A97.74,97.74,0,0,1,40,98.31,104.34,104.34,0,0,1,68.31,70.4a.61.61,0,0,0-.07.14A91.25,91.25,0,0,1,99.31,57.05c-3.44,1-6.84,2.18-9.86,3a103.21,103.21,0,0,1,48.49-2.17,108.41,108.41,0,0,0-34.46,1.85A96.89,96.89,0,0,0,71.14,73.24,90.82,90.82,0,0,0,46.05,97.72,83.58,83.58,0,0,0,32.84,129.3c2.28-6,4.38-12.88,7.36-19.34s6.73-12.35,11-15.85a91.67,91.67,0,0,0-19.73,57l-.51-4.6a60.35,60.35,0,0,0,1.07,20,105.09,105.09,0,0,0,6.23,19.12c.45,1.09.9,2.17,1.4,3.24l-1.4-3.24a91.64,91.64,0,0,1-6.79-34.52c.6,5.28,1.18,10.83,2.41,17.43,0-3.7-.57-8.86-.55-14a83.56,83.56,0,0,1,1.23-20.12,69.33,69.33,0,0,0,1.72,29.46c-1.66-13.64-.66-28,4-40.88A83.29,83.29,0,0,0,36.77,145a82.49,82.49,0,0,0,5.81,37.22L42,180.88c.37.9.79,1.79,1.2,2.69a82.1,82.1,0,0,0,7.27,13.32,48.5,48.5,0,0,0,9.33,9.69l1.57,1.57c-1.23-.75-2-1-.19,1.1a56,56,0,0,0,14.24,11.49c5.46,3.26,11.36,6,17.53,8.92A44,44,0,0,0,106,232.88a4.1,4.1,0,0,0,2.8.25c1.11.09,2.24.15,3.36.2a45.54,45.54,0,0,0,8.17.07c-2.66,0-5.42,0-8.17-.07l-3.06-.27a6.79,6.79,0,0,1,3-.37,84,84,0,0,1-27.23-7.91,89.56,89.56,0,0,1-23.59-16.63c1,.61,2.43,1.53,3.07,1.83-1.59-1.06-3.12-2.21-4.64-3.4A93.38,93.38,0,0,1,48,191.82a23.17,23.17,0,0,0,3.55,3.82,88.8,88.8,0,0,1-11.29-24.1A87,87,0,0,1,36.77,145,83.91,83.91,0,0,1,54.68,99.27a66,66,0,0,0-14.39,23.67A81.2,81.2,0,0,1,59.53,90,77.17,77.17,0,0,1,91.78,69.91c-3.88,2.76-9,6.32-10.53,9.2.54.54,7.53-2.62,3.76-.18-6.67,4.7-12.05,8.9-16,13s-6.36,8-6.41,11.84c.14.84,3.69-1.4,7-2.79s6.12-2.14,4.62-.1a81.84,81.84,0,0,0-11,16.16,48,48,0,0,0-3.31,6.3,2.84,2.84,0,0,0-.11,1.54,84.14,84.14,0,0,0-4.5,20.61c-.2,1.67-.3,3.33-.35,5a8.4,8.4,0,0,1-.93,2.26c.39,1.05.72,2.09,1,3.12A60.65,60.65,0,0,0,57.2,169a54.76,54.76,0,0,0,1.52,7.37c.25-.17.45-.7.9-.39A63.76,63.76,0,0,0,68,190.36a46.17,46.17,0,0,1,2.81,5.84c3.08,1.32,6.85,4.57,11.33,7.7a57.45,57.45,0,0,0,14.24,7.71l0-.08a69.47,69.47,0,0,0,14.22,3.88,21.27,21.27,0,0,1,2.22,1.19c1.29-.3,2.58-.22,3.22-.41,4,.6,7.37,1.07,10.87,1.32a9.68,9.68,0,0,1,3-1.46,45.83,45.83,0,0,0,7.53-1.47,76.46,76.46,0,0,0,8.51-2.44,74,74,0,0,0,25.74-15.48,2.3,2.3,0,0,1,1.2.44c.68-1.53,2.46-2.93,3.1-4.25-.06.3,0,.54.17.64a19.76,19.76,0,0,1,3-4.11,28.62,28.62,0,0,0,3.18-3.59,17.14,17.14,0,0,0,.91-2.7c.27-.39.52-.79.77-1.18,3.9-3.43,5.25-8.31,6.75-13.49a73,73,0,0,0,4.06-16c.51-4.36,1.65-6.09,2.24-9.28" style="fill:#189ab6"/><path d="M86.11,207.89A70.3,70.3,0,0,0,98.67,215c-4.88-1.66-9.5-3.13-12.56-7.08" style="fill:#189ab6"/><path d="M77.47,99.41a40.91,40.91,0,0,0,5.72-2.35,63.53,63.53,0,0,0-21.35,26.08l-.09,0a54.61,54.61,0,0,1,8-13.2c3.17-4.14,6.41-7.59,7.76-10.51" style="fill:#189ab6"/><path d="M76,199.74a6.5,6.5,0,0,1,.69.21l0,0a2.07,2.07,0,0,1-.72-.25" style="fill:#189ab6"/><path d="M90.41,72.94l1.31-.48a93.24,93.24,0,0,0-9.45,4.82,44.27,44.27,0,0,1,8.14-4.34" style="fill:#189ab6"/><path d="M127.73,68.53a79.51,79.51,0,0,1,21,4.32,63.37,63.37,0,0,1,22.06,14.9,80.85,80.85,0,0,0-43.08-19.22" style="fill:#189ab6"/><path d="M96.85,88.81a52.57,52.57,0,0,1,7.08-1.06,60,60,0,0,0-6.74,2c.31-.43-.19-.67-.34-.93" style="fill:#189ab6"/><path d="M66,89.35l1.58-1.45c-1.2,1.42-2.36,2.85-3.45,4.34.33-.61,1.25-1.92,1.87-2.89" style="fill:#189ab6"/><path d="M121.69,86.4c-1.7-.14-3.41-.2-5.11-.17,1-.24,2-.51,3-.86a7.34,7.34,0,0,0,2.1,1" style="fill:#189ab6"/><path d="M147.25,92.28a42.6,42.6,0,0,1,5.85,3.43,67.87,67.87,0,0,0-7.32-3.58c.68,0,1.25,0,1.47.15" style="fill:#189ab6"/><rect x="372.66" y="262.36" width="681.32" height="0.62" style="fill:#415870"/><path d="M423.46,298.65c0,1.82-1.14,2.11-4.95,2.16-3,.06-6,.12-9.83.29-3.24.11-7.16.34-9.2.51,0,.23.06.34.23,2.95a47.15,47.15,0,0,1-1.48,10.4,77.69,77.69,0,0,0-1.82,13.86c-.11,3.3-.17,6.48-.17,9a2.36,2.36,0,0,1-2.5,2.5c-1.42,0-2.9-.74-2.9-2.22s.23-5,.51-7.67a133.42,133.42,0,0,1,1.71-14c.79-4.65,1.53-8.58,1.59-10.05a19.31,19.31,0,0,0-.85-4.72l-3,.17c-4.66.29-10.62.57-14.77.57-1.82,0-3.41,0-3.41-2.16,0-1,1.48-1.82,4.21-2l13.75-1,3.06-.46a2.9,2.9,0,0,1,2.5-1.47,5.32,5.32,0,0,1,3.07,1.64c3,0,14.32-.39,20.11-.85,1.88,0,3.81.46,4.1,2Z" style="fill:#415870"/><path d="M440.14,325.53a69.05,69.05,0,0,0-1,10.23,2.37,2.37,0,0,1-2.67,2.49,2.71,2.71,0,0,1-2.5-2.72c.85-6.65.91-6.76.91-6.88.68-4.43,1.7-12.55,1.7-14.88a3.45,3.45,0,0,0-.17-1.31c-2.1.63-7.1,4.83-10.62,11.82-1.08,2.1-2,4-3.41,6.76L421,334.22c-1.2,2.44-1.93,3.07-3.75,3.07-1.08,0-2-1.31-2-2.84v-.29l1.65-13.29c.34-2.73,1-8.3,1.65-13.41L420,295.93c.29-2.33,1-7.16,3.69-7.16,1.82,0,2.22.74,2.22,1.76,0,.45-.11,1-.17,1.59l-.57,3.24c-2.27,15.11-2.95,21-3.46,27.1l.51-.62.68-1.14c.06-.17.17-.23.23-.4a44.1,44.1,0,0,1,4.31-5.74l2.33-2.44c3-2.95,6.08-6.08,8.24-6.08,3.18,0,3.3,3.69,3.3,6.19v1Z" style="fill:#415870"/><path d="M456.45,337.86c-8.58,0-10.45-8.18-10.45-12.39a4.49,4.49,0,0,1-.06-.68c0-.34.06-.8.11-1.59h-1.42c-1.36,0-3.69-.23-3.69-2.22s1.25-2.21,2.9-2.21a27.55,27.55,0,0,1,3.07.05c1.81-3.12,7.1-11.64,12.38-11.64,4.09,0,12.61,2.16,12.61,9.31a9.4,9.4,0,0,1-.39,3.47c-.4,1-1.71,1.08-3.53,1.08l-5.62.34a113.33,113.33,0,0,0-11.59,1.42,12.25,12.25,0,0,0-.06,1.59v1.31c0,.4.23,8.18,6.14,8.18,3.63,0,9.66-2.9,14.15-5.17a11.44,11.44,0,0,1,4.37-1.42A1.44,1.44,0,0,1,477,328.6c0,1-1.42,1.81-2.67,2.38a10.54,10.54,0,0,1-1.59.74C467.42,334.62,461.11,337.86,456.45,337.86Zm10.23-24.15a11.4,11.4,0,0,0-6.48-2.5c-2.1,0-6.08,4.32-8,7.22.79-.06,2.21-.29,2.95-.34l8.53-.74a18.43,18.43,0,0,0,3.46-.4,6.83,6.83,0,0,0,.23-1.54A2.52,2.52,0,0,0,466.68,313.71Z" style="fill:#415870"/><path d="M530.53,299.22l-1.08,3.3c-.8,3.86-1.65,10.57-2.28,14.54l-.17,1c-.39,3-.39,8.74-.62,12,0,.12.17.23.23,5.69v.34c0,1.25.11,2.72-2.9,2.72-1.31,0-1.88-.51-2.05-4.37a142.91,142.91,0,0,1,.34-15.23c-2.5.23-11.13,1.08-15.39,1.82-.17.74-.29,1.36-1,8.47-.22,1.87-.34,3.63-.56,5.11-.34,2.16-.86,3.63-2.67,3.63s-2.62-1.41-2.62-3.23a21.26,21.26,0,0,1,.34-2.67l.17-1.14c.4-2.61.91-6.19,1.25-9.77-1.42.05-3.23.17-5.34.17-2.72,0-3.86-.29-3.86-1.88,0-2.16,1.65-2.33,3.64-2.5l6.47-.62a23.89,23.89,0,0,0,.63-3.24c.34-2.67,1.87-11.36,2-13.64.17-2.67.74-5.17,3.92-5.17,1.65.17,1.88,1.2,1.88,2.33,0,2.16-1,4.83-1.48,7.67l-1.53,8.18c-.29,1.54-.34,1.77-.57,3.3,3.64-.23,6-.45,11.82-1.08l3.46-.17c.12-.45.34-2,.85-5.17.69-4.38,1.48-10.51,2.22-11.93.91-1.31,1.7-2.39,3.07-2.39a2.14,2.14,0,0,1,2.1,2.27Z" style="fill:#415870"/><path d="M557.51,312.29c-.68,0-2.44-.06-3.69-.06H553c-.06,0-1.93-.11-3.69-.11h-.86a12.55,12.55,0,0,1,3.3,9c0,4.2-3.3,15.56-12.22,15.56-6.53,0-7.84-6-7.84-10.51,0-4.14,2.62-14.88,12.84-18.46a2.43,2.43,0,0,1,.68-.06,12,12,0,0,1,2.5.34,3.68,3.68,0,0,0,.63.12s6.25.05,8.69.05h1.59c1.76,0,3,1.08,3,2.16-.39,1.65-2.1,2-3.12,2Zm-15,1.36c-2.72,1.88-5.79,7.28-5.79,13.13v.91c0,2.72,2,5.05,3.12,5.05,3.81,0,7.45-6.93,7.45-10.51A10.28,10.28,0,0,0,542.51,313.65Z" style="fill:#415870"/><path d="M586.44,333.71v-.8c0-4,.57-6.25,1.14-11.53l.79-7.1a5.48,5.48,0,0,0,0-1c-1.48.74-6.08,5.73-8.64,9.37-2.5,4.26-4.37,8.81-4.72,11.59-.28,1.36-1.93,2-3.4,2-2.11,0-2.16-1.88-2.16-2.79,0-1.25.45-2.67,2.27-11.64a26.19,26.19,0,0,0,.57-3,27.06,27.06,0,0,0,.57-5.4c0-.17,0-.22-.06-.22-.63,0-2.5,2.1-3.58,3.46a35.07,35.07,0,0,0-5.17,7.62l-2.73,7c0,.29-.17.34-.79,2.5a2.92,2.92,0,0,1-2.9,2.45c-2.27,0-2.27-1.42-2.27-2.45v-.45c.68-4.15.68-4.2.68-4.2a48.27,48.27,0,0,0,1-4.89c.4-2.22.46-2.33.46-2.5.51-4.21,1.13-5.46,1.42-9.94v-.29c0-1.76,0-4.15,3-4.15,1.7,0,2.27,1.59,2.5,3.13a51.79,51.79,0,0,1-1.19,7.78c3-4.09,8.35-10.45,11.76-10.45,1.19,0,3,.4,3,3.29a49.88,49.88,0,0,1-.68,8.07,65.9,65.9,0,0,1,5.28-6.08c2.73-2.44,6.76-5.34,8.69-5.34a2.81,2.81,0,0,1,2.67,3c-.34,3.92-.56,6-.79,7.21v.4c-.29.28-.34,1.82-.46,3.64l-.34,2.72a61.26,61.26,0,0,0-.85,7.62v.34c0,.68.17,1.7.17,2.38,0,1.42-.51,2.56-2.9,2.56C586.73,337.63,586.44,335.47,586.44,333.71Z" style="fill:#415870"/><path d="M610,337.86c-8.58,0-10.45-8.18-10.45-12.39a4.49,4.49,0,0,1-.06-.68c0-.34.06-.8.11-1.59H598.2c-1.36,0-3.69-.23-3.69-2.22s1.25-2.21,2.9-2.21a27.37,27.37,0,0,1,3.06.05c1.82-3.12,7.11-11.64,12.39-11.64,4.09,0,12.61,2.16,12.61,9.31a9.4,9.4,0,0,1-.39,3.47c-.4,1-1.71,1.08-3.53,1.08l-5.62.34a113.33,113.33,0,0,0-11.59,1.42,12.25,12.25,0,0,0-.06,1.59v1.31c0,.4.23,8.18,6.14,8.18,3.63,0,9.66-2.9,14.14-5.17a11.54,11.54,0,0,1,4.38-1.42,1.44,1.44,0,0,1,1.59,1.31c0,1-1.42,1.81-2.67,2.38a11.34,11.34,0,0,1-1.59.74C621,334.62,614.68,337.86,610,337.86Zm10.23-24.15a11.4,11.4,0,0,0-6.48-2.5c-2.1,0-6.08,4.32-8,7.22.79-.06,2.21-.29,3-.34l8.52-.74a18.44,18.44,0,0,0,3.47-.4,7.45,7.45,0,0,0,.23-1.54A2.52,2.52,0,0,0,620.25,313.71Z" style="fill:#415870"/><path d="M702.57,286.17c-7.84,0-17.44,5.05-18.92,11.76l-2,9.37c-1.7.29-15.16,1-17.66.67a14.63,14.63,0,0,0-2.5-.34,2.46,2.46,0,0,0-.69.06c-10.22,3.58-12.84,14.32-12.84,18.46,0,4.49,1.31,10.51,7.85,10.51,8.91,0,12.21-11.36,12.21-15.56a12.55,12.55,0,0,0-3.3-9h.86c.8,0,12.5.24,15.9-.16l-.73,6.82c-.8,7.16-2.28,15.34-3.47,21.7l-.23,1.25c-.74,4-1.47,4.66-1.47,6.59,0,1.42.56,2.27,1.93,2.27,2.55,0,2.44-1.08,2.78-2,.06-.11.29-1.88.29-2l2.32-10.06L685,322.93c1.08-8.3,1.13-10.23,1.13-11v-.34a75.72,75.72,0,0,0,9.38-1.19l5.22-.68c3-.34,4.32-1,4.32-2.62,0-1.3-1.82-1.76-1.87-1.76l-8.7,1c-1.87.39-4.71.51-6.47.68l-1,.11a64.23,64.23,0,0,1,2-8.24c1.93-5.22,6.71-8.12,13.69-8.12a23.29,23.29,0,0,1,7.79,1.82,5.94,5.94,0,0,0,2.21.85,1.94,1.94,0,0,0,1.93-1.93C714.61,288.44,708.25,286.17,702.57,286.17ZM656.1,332.74c-1.14,0-3.13-2.33-3.13-5.05v-.91c0-5.85,3.07-11.25,5.8-13.13a10.29,10.29,0,0,1,4.77,8.58C663.54,325.81,659.9,332.74,656.1,332.74Z" style="fill:#415870"/><path d="M748.19,300c-2.21,0-7.67,1.87-12.84,4.49-6.08,3.07-11.48,7.27-11.87,8.86-.23.91,3.12,1.08,10.73,1.65,1,.06,13.53.85,13.64,7.33.06,4.09-6.08,9.54-11.36,13.35-3.58,2.27-9.78,5.4-14.21,5.4-2.16,0-6.13-.86-6.13-3.53a2.18,2.18,0,0,1,2.27-2,6,6,0,0,0,3.86,1c4.09-.28,7.39-1.59,11.37-4,4.83-2.9,9.43-7,9.37-9.44.06-.28-.62-1.81-3-2.61a32,32,0,0,0-6.42-1.08l-8.81-.74c-3.8-.51-6.87-1.64-6.87-4.77,0-4.54,10.17-10.23,15.4-12.84l1-.51c3.81-1.82,10.85-5.06,14.26-5.06,1.54,0,3.18.23,3.18,2C751.71,300,750.07,300,748.19,300Z" style="fill:#415870"/><path d="M771,333.65c-4.09,2.05-8.92,4.32-14.2,4.32-5,0-7.62-3.69-7.62-8.52a23.35,23.35,0,0,1,2.73-10.74c2-3.75,8.64-10,13.81-10,2,0,6.25,1.59,6.25,3.75a2.73,2.73,0,0,1-2.73,2.27,2.31,2.31,0,0,1-1.71-.91,2.2,2.2,0,0,0-1.59-.73c-3.63,0-6.25,3.18-8.92,6.07h.06a17.5,17.5,0,0,0-3.07,10c0,1.47.4,4.65,3.3,4.65,4.88,0,8.07-1.47,12-3.58,6.36-3.58,7.21-3.92,7.38-3.92a2.23,2.23,0,0,1,2,2c0,1.08-2.05,2.22-4,3.35l-1,.57Z" style="fill:#415870"/><path d="M779.87,335.07c0,.12-.06.23-.06.34-.28,1.25-.74,3.3-3.35,3.3-1.93,0-2-1.08-2-2.44a7.54,7.54,0,0,1,.17-1.65c1.08-5.11,3.24-17.56,3.52-23.18.06-1.37,0-3.64,2.33-3.64,1.94,0,2.73,1,2.73,3a51.87,51.87,0,0,1-.68,7.56,41.11,41.11,0,0,1,8.52-7.22,34.26,34.26,0,0,1,10.63-4.37c2.84-.4,4.6,1,4.6,1.87,0,1.88-1.93,2.05-3.81,2.22l-1.31.11A38.25,38.25,0,0,0,792,315.7C782.43,322.23,781.4,330.41,779.87,335.07Z" style="fill:#415870"/><path d="M821.75,335.36a37.74,37.74,0,0,1,.57-5.85l1.42-8c-.74,1-1.53,2.05-2.67,3.75a71.31,71.31,0,0,1-7.61,9.38l-.46.4c-1.36,1.19-3.18,2.78-5.51,2.78-1.82,0-3.29-.74-3.29-3.29,0-.29.17-5.34.23-5.69l.62-5.34c0-.22,1-5.39,1.65-8,0-.12,0-.17,0-.29.63-2.72,1.82-7.78,4.78-7.78a2.33,2.33,0,0,1,2.21,2.61c-.17,2.5-2.33,7.22-3.06,11.25a103.64,103.64,0,0,0-1.54,11c0,.17.06.22.06.22,1,0,6.19-7,10.28-12.16l6.88-10.56a3.29,3.29,0,0,1,2.5-1,2.4,2.4,0,0,1,2.55,2.39v.34c-.62,2.61-1.25,4.83-1.76,6.42a35.82,35.82,0,0,0-1.82,7c-.05.63-.11,1.14-.17,1.71-.62,6.19-.74,7.73-.74,8.41v.34c.06.68.17,1.42.17,1.7,0,1-.39,1.76-2.32,1.76C822.44,338.88,821.75,337.86,821.75,335.36Z" style="fill:#415870"/><path d="M863.75,333.71v-.8c0-4,.57-6.25,1.14-11.53l.79-7.1a5.48,5.48,0,0,0,0-1c-1.48.74-6.08,5.73-8.64,9.37-2.5,4.26-4.38,8.81-4.72,11.59-.28,1.36-1.93,2-3.41,2-2.1,0-2.15-1.88-2.15-2.79,0-1.25.45-2.67,2.27-11.64a26.19,26.19,0,0,0,.57-3,27.76,27.76,0,0,0,.56-5.4c0-.17,0-.22-.05-.22-.63,0-2.5,2.1-3.58,3.46a35.07,35.07,0,0,0-5.17,7.62l-2.73,7c0,.29-.17.34-.79,2.5a2.92,2.92,0,0,1-2.9,2.45c-2.27,0-2.27-1.42-2.27-2.45v-.45c.68-4.15.68-4.2.68-4.2a48.27,48.27,0,0,0,1-4.89c.4-2.22.45-2.33.45-2.5.52-4.21,1.14-5.46,1.42-9.94v-.29c0-1.76,0-4.15,3-4.15,1.7,0,2.27,1.59,2.5,3.13a51.79,51.79,0,0,1-1.19,7.78c3-4.09,8.35-10.45,11.76-10.45,1.19,0,3,.4,3,3.29a49.88,49.88,0,0,1-.68,8.07,64.39,64.39,0,0,1,5.28-6.08c2.73-2.44,6.76-5.34,8.69-5.34a2.81,2.81,0,0,1,2.67,3c-.34,3.92-.57,6-.79,7.21v.4c-.29.28-.34,1.82-.46,3.64l-.34,2.72a59.41,59.41,0,0,0-.85,7.62v.34c0,.68.17,1.7.17,2.38,0,1.42-.51,2.56-2.9,2.56C864,337.63,863.75,335.47,863.75,333.71Z" style="fill:#415870"/><path d="M1180.25,139.75h-5.07v-4.1h14.75v4.1h-5.07v13.47h-4.61Zm13.44-4.1h6.18l4.18,11.43,4.17-11.43h6.19v17.57h-4.61V141.8h-.08l-4.18,11.42h-3l-4.18-11.42h-.08v11.42h-4.6Z" style="fill:#405870"/></svg>          </a>
        </div>
        <div class="secondary-nav-close-btn" id="js-secondary-nav-close-btn">
          X
        </div>
        <div class="nav-wrapper" id="js-nav-wrapper">
             
<nav role="navigation"  id="block-utilitynav" class="block-utilitynav">
                  
              <ul class="site-utility-nav">
                                  <li 
                  id="js-login-btn"
          class="login-btn"
                                        >
          <a href="/user/login" data-drupal-link-system-path="user/login">login</a>
                </li>
                      <li 
                                  id="js-register-btn"
          class="register-btn"
                        >
          <a href="/user/login" data-drupal-link-system-path="user/login">register</a>
                </li>
                      <li 
                                        >
          <a href="/partners" data-drupal-link-system-path="node/730">partners</a>
                </li>
                      <li 
                                        >
          <a href="/support/support-center-faq" data-drupal-link-system-path="node/16283">support</a>
                </li>
                <li class="hidden-xs hidden-sm social-search-icon">
        <a href="/search" id="js-search-btn"><span class="visually-hidden">Search</span><i class="fa fa-search fa-lg"></i></a>
      </li>
        </ul>
  


  </nav>
<div class="block-mainnavigation block block-menu navigation menu--main">
  
  <nav class="block-mainnavigation block block-menu navigation menu--main" role="navigation">
          
  <ul class="site-main-nav">
    <li id="js-nav-home-btn" class="site-main-nav-home-btn slide-nav-top-item">
      <a href="/">Home</a>
    </li>
                                <li  class="item-with-sub">
                      <a href="/about">About Us</a>
                      <i class="fa fa-angle-right"></i>
            <ul class="site-main-nav-secondary">
              <li class="slide-nav-back-btn">
                <span>Back <i class="fa fa-angle-left"></i></span>
              </li>
              <li class="slide-nav-top-item">
                                                  <a href="/about">About Us</a>
                              </li>
                             <li class="second-level-menu-item">
                 <a href="/about">Overview</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/why-scrumorg">Why Scrum.org</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/about/news">News</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/careers">Careers</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/scrumorg-staff">Meet Our Staff</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/find-trainers">Meet Our Trainers &amp; Coaches</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/about-us/scrumorg-diversity-and-inclusion">Diversity and Inclusion</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/about/contact-us">Contact Us</a>
              </li>
                          </ul>
          </li>
                                        <li  class="item-with-sub">
                      <a href="/courses">Training</a>
                      <i class="fa fa-angle-right"></i>
            <ul class="site-main-nav-secondary">
              <li class="slide-nav-back-btn">
                <span>Back <i class="fa fa-angle-left"></i></span>
              </li>
              <li class="slide-nav-top-item">
                                                  <a href="/courses">Training</a>
                              </li>
                             <li class="second-level-menu-item">
                 <a href="/courses">Overview of Courses</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/classes">View Class Schedule</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/find-trainers">Request a Private Class</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/find-trainers">Find a Trainer or Coach</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/become-professional-scrum-trainer">Become a Professional Scrum Trainer</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/scrumorg-training-reviews-and-testimonials">Reviews by Students</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/professional-scrum-competencies">Professional Scrum Competencies</a>
              </li>
                          </ul>
          </li>
                                        <li  class="item-with-sub">
                      <a href="/professional-scrum-certifications">Certification</a>
                      <i class="fa fa-angle-right"></i>
            <ul class="site-main-nav-secondary">
              <li class="slide-nav-back-btn">
                <span>Back <i class="fa fa-angle-left"></i></span>
              </li>
              <li class="slide-nav-top-item">
                                                  <a href="/professional-scrum-certifications">Certification</a>
                              </li>
                             <li class="second-level-menu-item">
                 <a href="/professional-scrum-certifications">Overview</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/professional-scrum-certifications/professional-scrum-master-assessments">Professional Scrum Master</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/professional-scrum-product-owner-certifications">Professional Scrum Product Owner</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/professional-scrum-developer-certification">Professional Scrum Developer</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/scaled-professional-scrum-certification">Scaled Professional Scrum</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/professional-scrum-with-kanban-certification">Professional Scrum with Kanban</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/professional-agile-leadership-certification">Professional Agile Leadership</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/professional-scrum-user-experience-certification">Professional Scrum with User Experience</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/certification-list">Search Professional Scrum Certificate  Holders</a>
              </li>
                          </ul>
          </li>
                                        <li  class="item-with-sub">
                      <a href="/open-assessments">Open Assessments</a>
                      <i class="fa fa-angle-right"></i>
            <ul class="site-main-nav-secondary">
              <li class="slide-nav-back-btn">
                <span>Back <i class="fa fa-angle-left"></i></span>
              </li>
              <li class="slide-nav-top-item">
                                                  <a href="/open-assessments">Open Assessments</a>
                              </li>
                             <li class="second-level-menu-item">
                 <a href="/open-assessments">Overview</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/open-assessments/scrum-open">Scrum Open</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/open-assessments/product-owner-open">Product Owner Open</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/open-assessments/scrum-developer-open">Scrum Developer Open</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/open-assessments/nexus-open">Nexus Open</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/open-assessments/scrum-kanban-open">Scrum with Kanban Open</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/open-assessments/agile-leadership-open">Agile Leadership Open</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/open-assessments/agile-measurement-open">Agile Measurement Open</a>
              </li>
                          </ul>
          </li>
                                        <li  class="item-with-sub">
                      <span>Community</span>
                      <i class="fa fa-angle-right"></i>
            <ul class="site-main-nav-secondary">
              <li class="slide-nav-back-btn">
                <span>Back <i class="fa fa-angle-left"></i></span>
              </li>
              <li class="slide-nav-top-item">
                                                  <span>Community</span>
                              </li>
                             <li class="second-level-menu-item">
                 <a href="/resources/blog">Blog</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/forum/scrum-forum">Forum</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/scrumorg-community-meetups">Meetups</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/events">Events</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/user/login">Join the Community</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/certification-list">Search Professional Scrum Certificate Holders</a>
              </li>
                          </ul>
          </li>
                                        <li  class="item-with-sub menu-item--active-trail">
                      <a href="/resources">Resources</a>
                      <i class="fa fa-angle-right"></i>
            <ul class="site-main-nav-secondary">
              <li class="slide-nav-back-btn">
                <span>Back <i class="fa fa-angle-left"></i></span>
              </li>
              <li class="slide-nav-top-item">
                                                  <a href="/resources">Resources</a>
                              </li>
                             <li class="second-level-menu-item">
                 <a href="/resources">View All Resources</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/resources/what-is-scrum">What is Scrum?</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/pathway/scrum-master">...for Scrum Masters</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/pathway/product-owner-learning-path">...for Product Owners</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/pathway/team-member-learning-path">...for Development Team Members</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/pathway/agile-leader-learning-path">...for Leaders</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/resources/scrum-guide">The Scrum Guide</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/resources/scaling-scrum">Scaling Scrum with Nexus</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/resources/suggested-reading-professional-scrum-kanban">Scrum with Kanban</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/resources/evidence-based-management">Evidence Based Management (EBM)</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="/resources/webcasts">Webcasts</a>
              </li>
                             <li class="second-level-menu-item">
                 <a href="https://www.scrum.org/resources?type=101">Videos</a>
              </li>
                          </ul>
          </li>
              </ul>

      </nav>
</div>

          <div class="megamenu-toggler" id="hamburger-menu-icon">
            <span></span>
          </div>
        </div>
      </div>
    </div>
  </div>
</header>
<div class="megamenu-wrapper" id="js-megamenu-wrapper">
  <div class="megamenu-search" id="js-search-dropdown">
    <div class="container">
      <div class="row">
        <div class="megamenu-search-interior">
            <div class="search-block-form block-scrumorg-search block" data-drupal-selector="search-block-form" role="search">
  
      
<form action="/search/node" method="get" id="search-block-form" accept-charset="UTF-8">
  
<div class="form-item form-group form-type-search form-item-keys form-no-label">
 
    

      
  

      <input title="Enter the terms you wish to search for." data-drupal-selector="edit-keys" type="search" id="edit-keys" name="keys" value="" size="20" maxlength="128" placeholder="Search" class="form-search form-type- form-control" />


        



        </div>

<div data-drupal-selector="edit-actions" class="form-actions js-form-wrapper form-wrapper" id="edit-actions">
  <input data-drupal-selector="edit-submit" type="submit" id="edit-submit" value="Search" class="button js-form-submit form-submit form-type- form-control" />


</div>

</form>


  </div>

 <span class="site-search-close-btn" id="js-site-search-close-btn">X</span>
        </div>
      </div>
    </div>
  </div>
  <div class="megamenu-login" id="js-login-dropdown">
    <div class="megamenu-back-btn" id="js-login-back-btn"><span>Back <i class="fa fa-angle-left"></i></span></div>
    <div class="megamenu-login-interior">
      <span class="login-close-btn" id="js-login-close-btn">X</span>
        <div class="block-logintitle-2 block-type--basic block">
  
      
            <div><h3>Login</h3></div>
      
  </div>
<div role="form" class="block-userlogin block">
  
      
<form class="user-login-form" data-drupal-selector="user-login-form" action="/resources/blog/test-first-approach-sounds-simply-enough-right?destination=/resources/blog/test-first-approach-sounds-simply-enough-right" method="post" id="user-login-form" accept-charset="UTF-8">
  
<div class="form-item form-group form-type-textfield form-item-name">
 
    

      <label for="edit-name" class="js-form-required form-required">Email address</label>
  

      <input autocorrect="none" autocapitalize="none" spellcheck="false" data-drupal-selector="edit-name" type="text" id="edit-name" name="name" value="" size="15" maxlength="60" placeholder="email address" class="form-text required form-type- form-control" required="required" aria-required="true" />


        



        </div>

<div class="form-item form-group form-type-password form-item-pass">
 
    

      <label for="edit-pass" class="js-form-required form-required">Password</label>
  

      <input data-drupal-selector="edit-pass" type="password" id="edit-pass" name="pass" size="15" maxlength="128" placeholder="password" class="form-text required form-type- form-control" required="required" aria-required="true" />


        



        </div>
<input autocomplete="off" data-drupal-selector="form-bi0t2k0wt-81seymlrnepjozi35-omkivo7jz1cjufe" type="hidden" name="form_build_id" value="form-bI0t2K0WT-81sEYmLrNepjOZI35_OmKiVo7JZ1CjUFE" class="form-type- form-control" />

<input data-drupal-selector="edit-user-login-form" type="hidden" name="form_id" value="user_login_form" class="form-type- form-control" />


<div data-drupal-selector="edit-actions" class="form-actions js-form-wrapper form-wrapper" id="edit-actions--2">
  <input data-drupal-selector="edit-submit" type="submit" id="edit-submit--2" name="op" value="Go" class="button js-form-submit form-submit form-type- form-control" />


</div>

</form>

<ul><li><a href="/user/password">Forgot Password</a></li></ul>
  </div>
<div class="block-loginregisterblock block-type--basic block">
  
      
            <div><h3>Not Registered?</h3>

<p>If you don't already have a Scrum.org account, you can sign up in just a few seconds.</p>

<p><a href="/user/login">Register Here</a></p></div>
      
  </div>


    </div>
  </div>
</div>
<div class="page-wrapper ">
  <div class="page-content">
    <div class="view-header-blocks">
        <div class="block-scrumorgblogsignup block">
  
      <div class="blog-signup">
        <p>Subscribe to our blog by signing up for the <a href="/subscribe-newsletter">Scrum.org newsletter</a>, or by subscribing to the RSS feed.</p>
        <div class="blog-subscribe-rss">
          <a href="/resources/blog/rss.xml">
            <i class="fa fa-rss"></i>&nbsp;RSS
          </a>
        </div>
      </div>
  </div>


    </div>
    <main role="main">
      <a id="main-content" tabindex="-1"></a>        <div data-drupal-messages-fallback class="hidden"></div><div class="block-scrumorg-content block">
  
      
<div class="blog-content-wrapper" id="resourceVueContainer">
  <div class="blog-nav-wrapper">
    <div class="blog-nav">
      <a class="blog-back-btn" href="/resources/blog">Back to Blog Listing</a>
              <a href="/resources/blog/handling-your-emotions-under-stress-crucial-effective-servant-leadership" class="blog-nav-prev">Prev</a>
                    <a href="/resources/blog/velocity-doesnt-measure-success">Next</a>
          </div>
  </div>
  <div class="blog-content-container">
    <div class="blog-content">
      <div class="blog-date">
        May 29, 2020
      </div>
      <h1 class="blog-title">
        
Test First approach sounds simply enough, right?  
      </h1>

      <div class="blog-author">

        
<div class="course-trainer">
  <div class="course-trainer-image">
    <img src="https://scrumorg-website-prod.s3.amazonaws.com/drupal/styles/profile_picture/s3/pictures/2018-11/ProfilePic-PPWhiteBackgroudv2.jpg?itok=v7T7cUah" alt="Profile picture for user Alexander Brown" typeof="foaf:Image" />
  </div>
  <div class="course-details-item-text">
          <p><i class="fa fa-user"></i> Alexander Brown</p>
        <p>
              <a href="http://www.bagile.co.uk" target="_blank">
          <span class="visually-hidden">Alexander Brown website</span>
          <i class="fa fa-globe"></i>
        </a>
                    <a href="https://twitter.com/ukalexbrown" target="_blank">
          <span class="visually-hidden">Alexander Brown Twitter</span>
          <i class="fa fa-twitter"></i>
        </a>
                    <a href="https://uk.linkedin.com/in/ukalexbrown" target="_blank">
          <span class="visually-hidden">Alexander Brown LinkedIn</span>
          <i class="fa fa-linkedin"></i>
        </a>
                          <a href="https://www.facebook.com/bagileuk/" target="_blank">
          <span class="visually-hidden">Alexander Brown Facebook</span>
          <i class="fa fa-facebook"></i>
        </a>
                    <a href="https://github.com/asbrown77" target="_blank">
          <span class="visually-hidden">Alexander Brown GitHub</span>
          <i class="fa fa-github"></i>
        </a>
                          <a href="/user/244234/contact">
          <span class="visually-hidden">Alexander Brown contact</span>
          <i class="fa fa-envelope"></i>
        </a>
            <a href="/alexander-brown" class="course-trainer-profile-link">View profile</a>
    </p>
  </div>
</div>


      </div>

              
        
        <div class="content-rating-row">
          <content-rating count="0"
                          average="0"
                          content-key="node:39589">
          </content-rating>
        </div>
      
      <div class="blog-info">
        <div class="blog-info-comments">
          <i class="fa fa-comment"></i>
          <a href="https://www.scrum.org/resources/blog/test-first-approach-sounds-simply-enough-right#disqus_thread" data-disqus-url="https://www.scrum.org/resources/blog/test-first-approach-sounds-simply-enough-right#disqus_thread" class="disqus-comment-count"></a>
        </div>
                  <div class="blog-info-tags">
            <i class="fa fa-tags"></i>
                          <a href="/resources/blog?topic=43">Test First</a>
                      </div>
              </div>

      
      <div class="blog-content-body">
        
            <div><p>As the name "Test First" suggests, you write a test first before the actual code and keep them running all the time. Well maybe not the second part explicitly. Yet what if I said to you that it actual means more than that?</p>

<p>Firstly it did originate from this simply meaning. When we hear the word “test”, a majority of us think in the traditional sense of checking (e.g validate the code). This can be the first confusion in its understanding and actual meaning today, for either technical or non-technical folk. If you’re not already aware, the way you think of testing within an agile approach is fundamentally different to the traditional one. But let us leave that for another day.</p>

<p>Then we have all these practices you hear about residing under this Test First banner - TDD, BDD, and ATDD. Are all these practices simply for writing tests first and automation? And what are the differences between all these practices, if any?</p>

<p>The name “Test First” has moved on from its original concept and has a broader meaning now. Over time it has evolved to incorporate the following</p>

<ul><li>Test Driven Development (TDD)</li>
	<li>Behavioural Driven Development (BDD)</li>
	<li>Ubiquitous Language for acceptance scenarios &amp; specifications e.g. Gherkin</li>
</ul><p>It has moved to enable quality focus on both the product and design by enabling faster feedback loops on several different level, than simply writing tests first before code.</p>

<p>The reason in 2011, Gojko Adzi introduce a different name to group these practices - “<a href="https://www.amazon.co.uk/Specification-Example-Successful-Deliver-Software/dp/1617290084" rel="noopener" target="_blank">Specification by Example</a>". With a redefined purpose statement "build the product right and building the right product". And the primary output being “living documentation” and collaboration and with automated tests being specified as the secondary output.</p>

<p>With people’s first exposure to Test First and the TDD and BDD practices there is a tendency to think it terms of traditionally testing. This can cause people to go further down the wrong rabbit hole and began automating their tests with an automation tool (e.g. Record and Play).</p>

<p>As with anything context is key, so I have found it useful to briefly explain the journey on how Test First and its associated practices have iteratively evolved to help people understand the meaning of Test First and understand each of the practices purpose, focus, differences, and benefits.</p>

<p><strong>Test-First Programming (est 1999)</strong></p>

<p>The term Test-First Programming (TP) was introduced by Kent Beck in 1999 with his book of “<a href="https://www.amazon.co.uk/Extreme-Programming-Explained-Embrace-Change/dp/0321278658/ref=sr_1_1?dchild=1&amp;keywords=Extreme+Programming+%28XP%29%3A+Explained&amp;qid=1590752060&amp;s=books&amp;sr=1-1" rel="noopener" target="_blank">Extreme Programming (XP): Explained</a>” and states to write unit tests before programming and keep all of the created tests running at all times. A year later, in 2000, Kent Beck published another book called “<a href="https://www.amazon.co.uk/Test-Driven-Development-Addison-Wesley-Signature/dp/0321146530" rel="noopener" target="_blank">Test Driven Development by Example</a>” and explains Test Driven Development (TDD) is a software process and not about writing tests before the code with one more important aspect – refactoring. The following is the sequence given in his book: -</p>

<ol><li>Add a test</li>
	<li>Run all tests and see if the new test fails</li>
	<li>Write the code</li>
	<li>Run Tests</li>
	<li>Refactor Code</li>
	<li>Repeat</li>
</ol><p>This cycle tends to be referred to as Red-Green-Refactor cycle. But Kent, and others, found that writing test first had a tremendous positive effect on the software architecture and design of software too:</p>

<ul><li>Testable</li>
	<li>Decoupled</li>
	<li>Reusable</li>
	<li>Independently Deployable</li>
	<li>Independently Developable</li>
	<li>Independently Reasonable</li>
</ul><p>This influence on software design and architecture became so important, beside the other positive effects, that Beck found it worthwhile to rename it from Test-First Programming to Test-Driven Development.</p>

<p><strong>Test-Driven Development 2.0 (est 2004)</strong></p>

<p>Test Driven Development moved slightly further, from Kent Beck’s original Red-Green-Refactor cycle, with Robert C Martin (aka Uncle Bob) and <a href="http://butunclebob.com/ArticleS.UncleBob.TheThreeRulesOfTdd" rel="noopener" target="_blank">The Three Laws of Test-Driven Development</a>.</p>

<ol><li>You are not allowed to write any production code unless it is to make a failing unit test pass.</li>
	<li>You are not allowed to write any more of a unit test than is sufficient to fail; and compilation failures are failures.</li>
	<li>You are not allowed to write any more production code than is sufficient to pass the one failing unit test.</li>
</ol><p>This is sometimes referred to as Test First with baby steps. Check out our <a href="https://www.bagile.co.uk/post/what-is-test-driven-development" rel="noopener" target="_blank">Introduction to Test Driven Development</a> video for more info.</p>

<p>Robert C. Martin went even further and focused on the 3rd Law. He discovered an approach called <a href="http://blog.cleancoder.com/uncle-bob/2013/05/27/TheTransformationPriorityPremise.html" rel="noopener" target="_blank">Transformation Priority Premise</a> in that a simple transformation should be preferred. The approach facilitates the programmer doing the simplest possible thing for the purposes of Test-Driven Development by favouring the simpler transformation (from the top of the list) over those further down in the list.</p>

<ol><li>({}–&gt;nil) no code at all-&gt;code that employs nil</li>
	<li>(nil-&gt;constant)</li>
	<li>(constant-&gt;constant+) a simple constant to a more complex constant</li>
	<li>(constant-&gt;scalar) replacing a constant with a variable or an argument</li>
	<li>(statement-&gt;statements) adding more unconditional statements.</li>
	<li>(unconditional-&gt;if) splitting the execution path</li>
	<li>(scalar-&gt;array)</li>
	<li>(array-&gt;container)</li>
	<li>(statement-&gt;recursion)</li>
	<li>(if-&gt;while)</li>
	<li>(expression-&gt;function) replacing an expression with a function or algorithm</li>
	<li>(variable-&gt;assignment) replacing the value of a variable.</li>
</ol><p>He goes on to suggest that we should amend the Red-Green-Refactor cycle of TDD with the following provisions</p>

<ul><li>When passing a test, prefer higher priority transformations.</li>
	<li>When posing a test choose one that can be passed with higher priority transformations.</li>
	<li>When an implementation seems to require a low priority transformation, backtrack to see if there is a simpler test to pass.</li>
</ul><p>And states if you follow these rules correctly then you should find</p>

<blockquote>
<p>As the test get more specific, the code gets more generic</p>
</blockquote>

<p><strong>Behaviour-Driven Development (est 2004)</strong></p>

<p>Behaviour Driven Development was developed by Dan North in response to help his colleagues to learn TDD. He found: -</p>

<ul><li>“Behaviour” is a more useful word than “test” – people’s misunderstanding about TDD always came back the word “test”</li>
	<li>Test method names should be a sentence and the word “test” can be stripped out</li>
	<li>A simple sentence template keeps test method focused. The class test method should do something &amp; only that thing</li>
	<li>An expressive test name is helpful when a test fails</li>
</ul><p>In 2003, Dan North created the JBehave framework to replace Junit to remove any reference to testing and replace a testing vocabulary around a behave one.</p>

<p>In 2004, the next discovery for Dan was the concept of business value and why we write software. He found that you could use his framework to help the team focus on feature behaviour and that missing requirement are behaviour too. Also, around this time Eric Evans published his bestselling book <a href="https://www.amazon.co.uk/Domain-Driven-Design-Tackling-Complexity-Software/dp/0321125215/ref=sr_1_1?dchild=1&amp;keywords=Domain-Driven+Design&amp;qid=1590752170&amp;s=books&amp;sr=1-1" rel="noopener" target="_blank">Domain-Driven Design</a>, where he describes the concept of modelling a system using a ubiquitous language based on business domain, so that the business vocabulary permeates right into the codebase. Dan and his colleagues used similar concept to come up defining a ubiquitous language for the analytics process itself, hence when the Given, When, Then for acceptance criteria came.</p>

<p>Since then many people have developed other BDD frameworks and then finally began framing BDD as a communication and collaboration framework for developers, QA and business in a software project. During the “Agile specification, BDD, and Testing eXchange” in November 2009 in London, Dan North gave the following description of BDD:</p>

<blockquote>
<p>BDD is a second-generation, outside-in, pull-based, multiple-stakeholder, high automation, agile methodology. It describes a cycle of interactions with well-defined outputs, resulting in the delivery of working, tested software that matters.</p>
</blockquote>

<p>During an interview with Dan North at GOTO Conference in 2013, Liz Keogh defines BDD as:</p>

<blockquote>
<p>It’s using examples to talk through how an application behaves. And having conversations about those examples</p>
</blockquote>

<p>Since Dan North’s first java base BDD framework of JBehave, the leading BDD framework is <a href="https://cucumber.io/" rel="noopener" target="_blank">Cucumber</a> and reads executable specifications written in plain text that follows some base rules called Gherkin. It used by majority of languages &amp; you can test about anything with it and build out test frameworks for your systems and products. It works well with other tools to enable testing of APIs, Browsers, and other system end points.</p>

<p><strong>What about Acceptance Test Driven Development ?</strong></p>

<p>Acceptance Test Driven Development or ATDD is where the entire team collaborates to define the acceptance criteria before implementation. It drives acceptance testing rather than unit testing by facilitating detailed readable description of system's function though proper examples and other necessary information. And with a focus on outside-in development approach. Sounds familiar?</p>

<p>Most of the time, BDD and ATDD are used interchangeably. The ATDD approach can be implemented using the Given-When-Then format and use BDD framework tools. But also we can use BDD frameworks for the TDD approach. Confused yet?</p>

<p>Personally using ATDD for 2 years before becoming aware of BDD. When I first heard the term, it confused me &amp; why was it different to what we were doing. Perhaps because we already practicing Domain Driven Development and using test framework with a Given-When-Then option. And "Acceptance Tests" can occur at more than the end to end tests but at component, integration and unit tests too.</p>

<p>Reading John Ferguson Smart "<a href="https://www.amazon.co.uk/BDD-Action-Behavior-driven-development-lifecycle/dp/161729165X" rel="noopener" target="_blank">BDD in Action</a>" book could help clear that confusion. I certainly wish it been around when I was introduced to BDD, as it would of helped me considerable.</p>

<p><strong>Summary</strong></p>

<p>In essence, the approach has evolved to be all about the conversation first between the business and development team to build the right product, and the developed using an outside-in workflow to build the product right that’s highly automated.</p>

<p>Understand each of the practices focus, outputs and benefits and use them when suits your needs. For example, because is an indicator to be an outside-in workflow, doesn't mean you can't go from inside-out. And don't bias yourself to tools, I'm using BDD tool so doing BDD.</p>

<p><img src="https://static.wixstatic.com/media/a66556_82b8e318779146f489cf756741e6a00e~mv2.png/v1/fill/w_740,h_430,al_c,lg_1,q_90/a66556_82b8e318779146f489cf756741e6a00e~mv2.webp" /></p>

<p>Personally I keep it simply and focus specific, use the BDD term when approach is about the collaboration with all stakeholders (customer, developer, tester, etc) to build the right product and produce living documentation that's readable by everyone to describe what the system can do. TDD is about design and building the product right.</p>

<p>Hope this helps.</p>

<p>If you'd like to know more or how we can help you or your teams incorporate these practices then contact us <a href="https://www.bagile.co.uk/technical-pratices-training" rel="noopener" target="_blank">here</a>.</p></div>
      
      </div>

        <div class="social-share-links-wrapper">
          <h3 class="social-share-links-title">Share this post</h3>
        <ul class="social-share-links">
      <li>
        <a rel="nofollow" href="mailto:?subject=%0ATest%20First%20approach%20sounds%20simply%20enough%2C%20right%3F%20%20&body=https://www.scrum.org/resources/blog/test-first-approach-sounds-simply-enough-right" target="_blank">
          <i class="fa fa-envelope"></i>
          <span>Email</span>
        </a>
      </li>
      <li class="share-facebook">
        <a rel="nofollow" target="_blank" href="https://www.facebook.com/sharer/sharer.php?u=https://www.scrum.org/resources/blog/test-first-approach-sounds-simply-enough-right" >
          <i class="fa fa-facebook"></i>
          <span>Facebook</span>
        </a>
      </li>
      <li class="share-twitter">
        <a rel="nofollow" href="https://twitter.com/share?text=%0ATest%20First%20approach%20sounds%20simply%20enough%2C%20right%3F%20%20&url=https://www.scrum.org/resources/blog/test-first-approach-sounds-simply-enough-right" target="_blank" title="Click to share on Twitter">
          <i class="fa fa-twitter"></i>
          <span>Twitter</span>
        </a>
      </li>
      <li class="share-linkedin">
        <a rel="nofollow" href="https://www.linkedin.com/shareArticle?mini=true&url=https://www.scrum.org/resources/blog/test-first-approach-sounds-simply-enough-right" target="_blank">
          <i class="fa fa-linkedin"></i>
          <span>LinkedIn</span>
        </a>
      </li>
      <li class="share-reddit">
        <a rel="nofollow"  href="https://reddit.com/submit?url=https://www.scrum.org/resources/blog/test-first-approach-sounds-simply-enough-right" target="_blank">
          <i class="fa fa-reddit"></i>
          <span>Reddit</span>
        </a>
      </li>
      <li class="share-pocket">
        <a rel="nofollow" href="https://getpocket.com/save" data-save-url="https://www.scrum.org/resources/blog/test-first-approach-sounds-simply-enough-right" target="_blank" title="Click to share on Pocket">
          <i class="fa fa-get-pocket"></i>
          <span>Pocket</span>
        </a>
      </li>
    </ul>
  </div>

              <div class="blog-tags-bottom">
                      <a href="/resources/blog?topic=43">Test First</a>
                  </div>
            <div class="blog-comments">
        
  <div>
    <div>Blog Comments</div>
              <div>
<div id="disqus_thread">
  <noscript>
  <p>
    <a href="http://scrumorg.disqus.com/">View the discussion thread.</a>
  </p>
</noscript>

</div>
</div>
          </div>

      </div>
    </div>
  </div>
  <div class="blog-nav-wrapper">
    <div class="blog-nav">
              <a href="/resources/blog/handling-your-emotions-under-stress-crucial-effective-servant-leadership" class="blog-nav-prev">Prev</a>
                    <a href="/resources/blog/velocity-doesnt-measure-success">Next</a>
          </div>
  </div>
</div>

  </div>


    </main>
  </div>
</div>

<footer class="site-footer">
  <div class="site-footer-container">
    <div class="site-footer-copyright"><p>&copy; 2020&nbsp;</p>  
<div class="block-footercopyrighttext block-type--plain_text_block block">
  
      
      Scrum.org. All Rights Reserved.
  
  </div>

</div>
        <div class="site-footer-nav">
        
<nav role="navigation"  id="block-scrumorg-footer" class="block-scrumorg-footer">
                  
              <ul class="site-footer-links">
                    <li>
            <a href="/about/contact-us" data-drupal-link-system-path="node/4998">Contact</a>
                  </li>
                <li>
            <a href="/privacy-policy" data-drupal-link-system-path="node/5080">Privacy</a>
                  </li>
                <li>
            <a href="/website-terms-service" data-drupal-link-system-path="node/8882">Terms of Service</a>
                  </li>
                <li>
            <a href="/scrumorg-trademarks-and-copyrights" data-drupal-link-system-path="node/15547">TM and © Guidelines</a>
                  </li>
          </ul>
  


  </nav>
<div class="block-socialnaviconsforheaderandfooter block-type--site_social_nav block">
  
      
<ul class="social-nav">
      <li>
    <a href="https://twitter.com/Scrumdotorg">
      <span class="visually-hidden">https://twitter.com/Scrumdotorg</span>
      <i class="fa fa-twitter"></i>
    </a>
  </li>
      <li>
    <a href="http://facebook.com/scrum.org">
      <span class="visually-hidden">http://facebook.com/scrum.org</span>
      <i class="fa fa-facebook"></i>
    </a>
  </li>
      <li>
    <a href="https://www.linkedin.com/company/scrum-org">
      <span class="visually-hidden">https://www.linkedin.com/company/scrum-org</span>
      <i class="fa fa-linkedin"></i>
    </a>
  </li>
      <li>
    <a href="https://www.youtube.com/user/Scrumorg">
      <span class="visually-hidden">https://www.youtube.com/user/Scrumorg</span>
      <i class="fa fa-youtube"></i>
    </a>
  </li>
  </ul>
 
  </div>


    </div>
  </div>
</footer>

  </div>


<div class="privacy-toast" style="display:none;">By using this site you are agreeing to the <a href="/privacy-policy">Privacy Policy</a> and <a href="/website-terms-service">Terms of Service</a>.<a href="javascript:void(0)" class="privacy-dismiss">X</a></div>
  <script id="dsq-count-scr" src="//scrumorg.disqus.com/count.js" async></script>
<script type="application/json" data-drupal-selector="drupal-settings-json">{"path":{"baseUrl":"\/","scriptPath":null,"pathPrefix":"","currentPath":"node\/39589","currentPathIsAdmin":false,"isFront":false,"currentLanguage":"en"},"pluralDelimiter":"\u0003","suppressDeprecationErrors":true,"ajaxTrustedUrl":{"form_action_p_pvdeGsVG5zNF_XLGPTvYSKCf43t8qZYSwcfZl2uzM":true,"\/search\/node":true},"disqus":{"domain":"scrumorg","url":"https:\/\/www.scrum.org\/resources\/blog\/test-first-approach-sounds-simply-enough-right","title":"Test First approach sounds simply enough, right?  ","identifier":"","disable_mobile":false},"user":{"uid":0,"permissionsHash":"1eb7892881ef175e78aebe7bbb484e2235cc787a6e3c31f803ea23f54e32dca6"}}</script>
<script src="/core/assets/vendor/jquery/jquery.min.js?v=3.4.1"></script>
<script src="/core/assets/vendor/jquery/jquery-htmlprefilter-3.5.0.js?v=3.4.1"></script>
<script src="/core/assets/vendor/jquery-once/jquery.once.min.js?v=2.2.0"></script>
<script src="/core/misc/drupalSettingsLoader.js?v=8.8.6"></script>
<script src="/core/misc/drupal.js?v=8.8.6"></script>
<script src="/core/misc/drupal.init.js?v=8.8.6"></script>
<script src="/themes/custom/scrumorg/js/scrumorg.js?qapico"></script>
<script src="/themes/custom/scrumorg/js/privacy.js?qapico"></script>
<script src="/modules/custom/scrumorg_general/js/vue/vendor.js?qapico"></script>
<script src="/themes/custom/scrumorg/js/dist/resource.js?qapico"></script>
<script src="/core/misc/debounce.js?v=8.8.6"></script>
<script src="/core/assets/vendor/jquery.cookie/jquery.cookie.min.js?v=1.4.1"></script>
<script src="/core/misc/form.js?v=8.8.6"></script>
<script src="/modules/contrib/disqus/js/disqus.js?v=1.x"></script>
<script src="/modules/contrib/disqus/js/disqus.settings.js?v=1.x"></script>

</body>
</html>
